Shop More Submit  Join Login
×




Details

Submitted on
May 7, 2012
Image Size
34.4 KB
Resolution
446×455
Link
Thumb
Embed

Stats

Views
9,603
Favourites
176 (who?)
Comments
127
×
Forum Cloud v. 0.7 by deviant-garde Forum Cloud v. 0.7 by deviant-garde

NOTE: this is currently broken due to Sta.sh Writer, but the script is being replaced with Comment CLOUD, which will be able to be used anywhere on the website instead of just the forums. If you want updates ask me or check my journals/this deviation.



Description


This script makes it easier to use emoticons on the Forums by taking advantage of Emote CLOUD This script will add:


  • A database of emote codes, like the ones for the official dA emotes, that can be used for user-created emotes. User-created emotes are just deviations. For example, you can type :8Bdance: in a comment to use .

  • A menu that displays these emotes alongside who made them and their vote count.

  • The ability to add an emote made by you or someone else to everybody's database of emote codes, and the ability to vote up/down existing ones. Multiple emotes can share the same code and the one with the highest votecount will be displayed when that code is used.




Releases



Version 0.7 (Jan 13, 2013) [current]

  • Numerous bugs with the interface were fixed. Notable ones include:
    • The links at the bottom of the really big comment box on the bottom of the thread no longer disappear when you click them if you didn't type something in first.

    • When you'd mouse over the deviation or vote links for an emote in the Forum Cloud menu, it would flicker over and over again. That's been fixed.

    • The Forum Cloud links for new threads used to display incorrectly.

  • Search has been implemented! Type something in the search box and hit enter, and it'll display emotes that match that text, ordered by vote count and alphabetical order.

  • There is now a built in link to the Emote Cloud.



Version 0.6.1 (Jul 30, 2012)
  • A very minor issue was fixed in Chrome which made it so the emote and menu info didn't disappear when you moved your mouse away from a menu item.


Version 0.6 (Jul 29, 2012)
  • Emote images now only show when hovering over their respective menu item.

  • Clicking on an emote code will add it to the text box.

  • You can now vote for public emotes. Click + to vote up an emote, and - to vote one down. The Emote Cloud only allows you a single vote per emote.

  • There is now a "view" link to view the deviation of the emote submitted.

  • New "Help" menu button.

  • Improved error handling mechanisms.

  • The menu shouldn't be noticeably lagging anymore.

  • It's prettier. :dummy:



Version 0.5.1 (June 5, 2012)
  • Fixed a severe bug which made it impossible to obtain a new emotes list.

  • In some browsers, the link to install Forum Cloud didn't work.


Version 0.5 (May 21, 2012)
  • Added forum cloud links to the message center and the box used to create a new thread.

  • Fixed glitch in the message center where posts that weren't to a forum had forum cloud enabled.



Version 0.4.1 (May 16, 2012)
  • I've re-added the links to the big commenting box.


Download Link



Click here and hit the "Install" button to get Forum Cloud.

You need Greasemonkey (Firefox Users) or TamperMonkey (Chrome Users) to use this script.

Click here to download Greasemonkey.
Click here to download TamperMonkey.

Note: Not to be a whore or anything, but if you want to track the updates to this script it would be a good idea to watch me so I can automatically notify you of updates in my journal. I might add an updater within the script itself eventually but not anytime soon.
Add a Comment:
 

Daily Deviation

Given 2012-09-25
Forum Cloud v. 0.6 by *deviant-garde is a great script that allows users to use their favourite emoticons in the forums with ease.

( Also suggested by ^namenotrequired )

deviantART Related / deviantART Skins & Scripts / Browser Scripts and Extensions ( Suggested by LOVEintheSNOW and Featured by bradleysays )
:iconi-is-smart:
I-is-smart Featured By Owner Aug 1, 2013  Hobbyist General Artist
Hey DG I am keeping an eye on this because I would really like to see a completed Comment-Cloud. I have been having fun using my own custom emotes on the site but I think if this extension is implemented it will be really helpful since I won't have to keep searching out my own emotes to use them.

so yeah no pressure but please finish the extension so I can be lazy   
Reply
:icondeviant-garde:
deviant-garde Featured By Owner Aug 1, 2013
Yeah, I noticed recently that searching really isn't good enough when you have an option like this. I'll be sure to work this out nice and soon :nod: In fact, if you're eager to use it, you could help me test it too.
Reply
:iconi-is-smart:
I-is-smart Featured By Owner Aug 1, 2013  Hobbyist General Artist
I would be happy to be a tester! I love being a guinea pig!
Reply
:icon290pika:
290Pika Featured By Owner Apr 24, 2013  Student Filmographer
My Forum Cloud isn't working. :nuu:

Did dA do some code changes or something very recently? :\
Reply
:icondeviant-garde:
deviant-garde Featured By Owner Apr 24, 2013
Thanks for indeed letting me know. What exactly is going wrong? Can you be specific about the errors or glitches you're running into? This is the best time to report them since I'm going to release 0.8 soon.

By the way, if you know anybody else who uses this and who may have ran into issues themselves, don't hesitate to direct them to me. :D
Reply
:icon290pika:
290Pika Featured By Owner Apr 24, 2013  Student Filmographer
It's enabled on my Greasemonkey, but I do not see it appearing anywhere on my comment box for forum replies. It only had to have happened recently though, since I use things like lawoo all the time and I just noticed within the past day or two that it stopped working. I made sure I had v0.7 too.

I also noticed a couple other dA scripts by others not working this week or so, like one that allows me to see group messages in my toolbar. It may or may not be related to dA coding?

I use Firefox.
Reply
:icondeviant-garde:
deviant-garde Featured By Owner Apr 24, 2013
Well, Forum Cloud works for me and while I do occasionally have fixes (that I didn't remember were part of the next upcoming version) which other people don't for a good while, I don't know what exactly it might be that broke it so much. I'm going to check into that further because I probably noticed the error and fixed it and didn't record it properly... I need to get Forum Cloud on GitHub so that doesn't keep happening!

Anyway, I do know for a fact that I had to update a URL or two where Forum Cloud was supposed to activate (like the Message Center, which is no longer at my.deviantart.com but www.deviantart.com) but any other odds and ends which I didn't already catch I'd need to investigate a little further. I can't remember if Forum Cloud broke for me so spectacularly since 0.7 was released. I can send you the current pre-release and you can see if those bugs clear up. Check your notes in the next minute. :paranoid:
Reply
:icon290pika:
290Pika Featured By Owner Apr 24, 2013  Student Filmographer
Okay, so I just posted a forum thread, and the links for Forum Cloud were showing up at the bottom of the screen (under the main submit box thing).

The message centre's URL changed?? Ah, so it has. I didn't notice til you pointed it out. It might just be that. Might also be why the other script isn't working.
Reply
:icondeviant-garde:
deviant-garde Featured By Owner Apr 24, 2013
Well don't forget that it works IN the threads too. On forum.deviantart.com and comments.deviantart.com as well. It doesn't just work in the message center.

And yeah, I noticed after they added the sidebar to the forums that the links got a little screwed up for new threads. I'm going to fix that too; thanks for reminding me.
Reply
:icon290pika:
290Pika Featured By Owner Apr 24, 2013  Student Filmographer
I usually use it in the message centre I think is the problem. :shifty: It is working regularly in the forum, though like you said the link is funny at the bottom of the thread submit box.

(I have a script disabling the sidebar so the links on forum.deviantart.com seem to be working normally.)
Reply
Add a Comment: